cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Are you interested in hearing how one of our Community members uses Dropbox for sailing trips? Read all about it here.

Apps and Installations

Have a question about a Dropbox app or installation? Reach out to the Dropbox Community and get solutions, help, and advice from members.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dropbox client refuses to finish installation (invalid URL)

Dropbox client refuses to finish installation (invalid URL)

FullScale4Me
Explorer | Level 3

Dropbox worked fine on MX Linux 21, based on Debian 11. I recently upgraded one of my PCs to MX Linux 23 (Xfce) based on Debian 12.

 

I have tried install installation from the MX Linux repository and in the recent past gotten an "key miss-match" error.

 

I then tried downloading the client from My Account. I was able to install it and got it somewhat running from the command line. The finish installation url that resulted also gave an Invalid URL error.

 

My system:


System:
Kernel: 6.4.0-1mx-ahs-amd64 [6.4.4-1~mx23+1] arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-6.4.0-1mx-ahs-amd64 root=UUID=<filter> ro quiet splash
Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm v: 4.18.0 vt: 7
dm: LightDM v: 1.26.0 Distro: MX-23_ahs_x64 Libretto July 31 2023 base: Debian GNU/Linux 12
(bookworm)
Machine:
Type: Desktop System: Dell product: OptiPlex 7050 v: N/A serial: <superuser required> Chassis:
type: 3 serial: <superuser required>
Mobo: Dell model: 0NW6H5 v: A00 serial: <superuser required> UEFI: Dell v: 1.21.0
date: 07/12/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331 serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: Intel Core i7-7700 bits: 64 type: MT MCP arch: Kaby Lake gen: core 7 level: v3
note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 9
microcode: 0xF2
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 2742 high: 3600 min/max: 800/4200 scaling: driver: intel_pstate
governor: powersave cores: 1: 3600 2: 1100 3: 3600 4: 3600 5: 3600 6: 1360 7: 1483 8: 3600
bogomips: 57600
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, HDMI-A-2,
HDMI-A-3 bus-ID: 00:02.0 chip-ID: 8086:5912 class-ID: 0300
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-4:3
chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 1.21.1.7 compositor: xfwm v: 4.18.0 driver: X:
loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915 display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer K242HYL serial: <filter> built: 2019
res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2 size: 527x296mm (20.75x11.65") diag: 604mm (23.8")
ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 630 (KBL GT2)
direct-render: Yes
Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel v: kernel
bus-ID: 1-4:3 bus-ID: 00:1f.3 chip-ID: 046d:0825 chip-ID: 8086:a2f0 class-ID: 0102
serial: <filter> class-ID: 0403
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
API: ALSA v: k6.4.0-1mx-ahs-amd64 status: kernel-api tools: alsamixer,amixer
Server-1: PipeWire v: 0.3.65 status: active with: 1: pipewire-pulse status: active
2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
chip-ID: 8086:15e3 class-ID: 0200
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 3.09 TiB used: 309.19 GiB (9.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingfast model: N/A size: 953.87 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 9B0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB model: USB3.0 size: 1.82 TiB block-size:
physical: 4096 B logical: 512 B type: N/A serial: N/A rev: 0204 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 type: USB model: USB3.0 size: 232.89 GiB block-size:
physical: 4096 B logical: 512 B type: N/A serial: N/A rev: 0204 scheme: GPT
ID-4: /dev/sde maj-min: 8:64 type: USB model: External USB3.0 size: 111.79 GiB block-size:
physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 0204 scheme: GPT
Partition:
ID-1: / raw-size: 355.47 GiB size: 348.82 GiB (98.13%) used: 27.43 GiB (7.9%) fs: ext4
dev: /dev/sda6 maj-min: 8:6
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 44.2 MiB (46.0%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 15 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: file size: 6 GiB used: 0 KiB (0.0%) priority: -2 file: /swap/swap
Sensors:
System Temperatures: cpu: 36.0 C mobo: N/A
Fan Speeds (RPM): N/A
Repos:
Packages: pm: dpkg pkgs: 2469 libs: 1376 tools: apt,apt-get,aptitude,nala,synaptic pm: rpm
pkgs: 0 pm: flatpak pkgs: 0
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list
1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ bullseye main
Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
1: deb http://deb.debian.org/debian bookworm-updates main contrib non-free non-free-firmware
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://deb.debian.org/debian bookworm main contrib non-free non-free-firmware
2: deb http://security.debian.org/debian-security bookworm-security main contrib non-free non-free-firmware
Active apt repos in: /etc/apt/sources.list.d/mx.list
1: deb http://mirrors.rit.edu/mxlinux/mx-packages/mx/repo/ bookworm main non-free
2: deb http://mirrors.rit.edu/mxlinux/mx-packages/mx/repo/ bookworm ahs
Active apt repos in: /etc/apt/sources.list.d/slack.list
1: deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main
Info:
Processes: 271 Uptime: 3d 15h 22m wakeups: 393 Memory: 31.21 GiB used: 4.97 GiB (15.9%)
Init: SysVinit v: 3.06 runlevel: 5 default: graphical tool: systemctl Compilers: gcc: 12
Client: shell wrapper v: 5.2.15-release inxi: 3.3.26
Boot Mode: UEFI

1 Accepted Solution

Accepted Solutions

izio
New member | Level 2

I also use MX Linux 23 and had the exact same error as yours. The following helped me:

1. deleted the old link to my MX 21 installation.
2. stopped Dropbox client via CLI (dropbox stop)
3. started Dropbox client via CLI (dropbox start)

 

After step 3 the browser was started and the link was valid. I was able to link the installation successfully. I am not sure if step number 1 is really necessary. But it does not hurt 🙂

Hope this helps you!

 

View solution in original post

1 Reply 1

izio
New member | Level 2

I also use MX Linux 23 and had the exact same error as yours. The following helped me:

1. deleted the old link to my MX 21 installation.
2. stopped Dropbox client via CLI (dropbox stop)
3. started Dropbox client via CLI (dropbox start)

 

After step 3 the browser was started and the link was valid. I was able to link the installation successfully. I am not sure if step number 1 is really necessary. But it does not hurt 🙂

Hope this helps you!

 

Need more support?
Who's talking

Top contributors to this post

  • User avatar
    izio New member | Level 2
What do Dropbox user levels mean?