Showing results for 
Show  only  | Search instead for 
Did you mean: 
Are you interested in hearing how one of our Community members uses Dropbox for sailing trips? Read all about it here.

Apps and Installations

Have a question about a Dropbox app or installation? Reach out to the Dropbox Community and get solutions, help, and advice from members.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re: Synchronization problem with Mac Os Sonoma

Won't stop indexing on Mac

New member | Level 2
Go to solution

I installed the mac dropbox update and the application began indexing my files. It has now been stuck for the last few days. I can only access some files. Many are now only available through and not in my app. If I add files to they are added to the indexing queue of the desktop app, but no progress is made regarding indexing. I've tried signing out, quitting, uninstalling, and reinstalling. I've seen similar threads, but no solutions have worked for me. Any help is much appreciated.

349 Replies 349

New member | Level 2

Thank you SO MUCH for posting this fix!! After fighting with the forever loop of indexing for the past 23 days, I came across your comment, signed out and back in again and problem fixed! Thank you SO MUCH.

Helpful | Level 6

I fixed it with a patch called OneDrive. Problem solved. At least I don’t have to listen to the garbage the official Dropbox support is spewing anymore. Toodaloo.

Collaborator | Level 9

Hello again fellow sufferers,


Below is the latest advice I have received. 


If you look carefully at the steps, essentially it is signing out, and signing back in. Something most of us have done, and some of us many, many times.


I post it here, just to pass this on. Maybe it will work for someone.


I have also done full erase and reinstall of Ventura 13.6 on two Mac's, thinking that Sonoma was the problem. But the problem of being stuck indexing persists on Ventura 13.6 and now 13.6.1 after full erase and reinstalls.


I wish I had some good news for you all, but I can't find a way to fix this problem and after all the weeks this problem has been known, it is clear that Dropbox does not know of a way to solve this problem.




Thank you for taking the time to write back to me!
Please follow the steps below and let me know if the same issue persists:
Step 1: Unlink the device from your account

  1. Right-click the Dropbox icon in the menu bar (macOS).
  2. Click your profile picture or initials on the top right and select "Preferences."
  3. Go to the Account tab.
  4. Click "Sign out.
  5. Click Sign out again to confirm.

Step 2: Rename the "Dropbox" folder

  1. Right-click the folder and select "Rename."
  2. Rename it to "Dropbox (Old)."

Step 3: Relink the Dropbox account

  1. Relaunch the Dropbox application.
  2. Click the Dropbox icon.
  3. Enter your login credentials when prompted.
  4. Choose your desired file sync settings and click "Continue."
  5. After successful installation, click "Advanced Settings" at the bottom.
  6. Under Selective Sync, click "Select Folders"
  7. Unselect all folders for selective sync and click "Update."

The process is complete. Let the application sync; it should quickly say "Up to date" since no data is syncing locally.
You can gradually add folders for local sync, but be aware of the 300,000 file limit, which may cause issues if exceeded.
Please let me know if the above steps helped. Looking forward to your reply!
Kind regards,




Durval L
Explorer | Level 4

@FrankieAnn, thank you for your cooperation. Indeed, these procedures worked for me. I don't know exactly whether this was a problem from Dropbox or Apple, but today I updated macOS Sonoma to version 14.1 and tried the "reboot" on Dropbox.

Best regards! 

Experienced | Level 11

Something strange is happening here. I'm still on Dropbox version 185.4.6054, and I'm using macOS Sonoma 14. I haven't updated to 14.1 yet.

What I've noticed is that the files that were supposed to be synchronized and 'online only' have been partially synchronized. Some of them are visible on, but not all. The cloud icon with an exclamation mark remains in the Finder, even when the file appears on

I've also noticed that a previously unseen option has appeared in the dropdown menu: 'Sync the next.' Clicking on it doesn't seem to do anything. However, I wanted to report what I've observed for the record.

Screenshot 2023-10-29 alle 09.20.44.jpg


Screenshot 2023-10-29 alle 09.20.52.jpg

As I've mentioned, what I'm experiencing doesn't seem to follow a clear logic because it happens with some files but not with others.

Experienced | Level 11

For over 20 days now, since the MacOS Sonoma update, I've been unable to use Dropbox. This means no more backups, no more file synchronization, no more sharing documents with colleagues, and no more convenience for me. It won't be long before my hard drive fills up, and at that point, the only way I'll have to clear space is by returning to the old external hard drives I had abandoned, favoring a paid Dropbox account.


It's been quite a letdown, and I'm very disappointed.

Josephus F.
Helpful | Level 5

DBox staff response to me that Sonoma and DB work fine together, it is love at first sight

Explorer | Level 4

Yes, indeed now it works

Helpful | Level 5

Forgive me, but has there been an update from Dropbox that fixed the issue, or are you being sarcastic?

Collaborator | Level 8

Hello I have been a long time Dropbox user. I have been having issues with sync on my Macbook.  I started having issues once I updated to the new Sonoma on Mac.    At work I use a PC and at home I use a Mac. When I get home and I start to use my Mac, its showing files are stuck on sync and on top of the file like an Excel file it has X marks on it with a bar showing its trying to sync but the bar does not fill up its just stuck on there. 

The only fix I can come up with is to Restart my Mac and then it will sync but I do not want to keep restarting it does not make sense. I tried to quit the app and go back in and pause and un pause and also gave full disk access but none of it works. If someone can help me.   

I tried everyting even uninstalled and reinstalled and nothing is working.

Need more support?