cancel
Showing results for 
Search instead for 
Did you mean: 

Experimental Build 3.11.45

747 Views
8 Comments
10 Kudos
Highlighted
Dropboxer

Experimental Build 3.11.45

Edit: There is a newer release candidate.

Happy Monday! We’ve got a new experimental build for you in the 3.11 series!

New in 3.11.45:

  • Fixes for LAN sync
  • Other bug fixes

New in the 3.11 series:

  • New functionality for the badge:
    • View if the document is shared, and change sharing permissions
    • Email file from the badge
  • UI improvements for the Tray Popup on Mac
  • Changes to how the client runs before a user signs in
  • Many small fixes and improvements

Download

     Windows      [Standard Installer] [Offline Installer]
     Mac OS X   [Standard Installer] [Offline Installer]
     Linux   [x86_64 Offline Installer] [x86 Offline Installer]

 

Auto-updates: 3.11.x clients

8 Replies
Level 1

Re: Experimental Build 3.11.45

Thanks for the new build. Unfortunately I can't see the dropbox icon in the system tray. I use opensuse Leap 42.1 and KDE with Plasma 5.4.2.

Where the icon should be is now just a gap.

Level 1

Re: Experimental Build 3.11.45

@Jens J.: That's a known bug in dropbox. It keeps getting reported, and dropbox keeps studiously not fixing it (and at least one other major linux bug).

I've been reporting this bug on these forums for at least 281 days and counting without a lasting fix. (The other bug I think might be a few days less than that).

See https://www.dropboxforum.com/hc/en-us/community/posts/203567443-Experimental-Build-3-11-44#community... for more details.

Come on Dropbox - I want to be able to say that you're better than this!

Level 3

Re: Experimental Build 3.11.45

Works fine on OS x 10.11.1

Re: Experimental Build 3.11.45

This version is the only version I could get to both install and sync without crashing after a clean install of Windows 10 1511 (Fall Update, installed from official ISO image).

v3.10.11 would install, prompt me for login, prompt me for 2FA code, and then crash immediately after 2FA code entry. I confirmed this on two different machines that I was clean installing Windows 10 1511 onto.

v3.11.45 installs and syncs properly after 2FA code entry.

Level 1

Re: Experimental Build 3.11.45

 I had the same problem as Jonathan A.  The 3.10.11 would install but immediately crash after logging in.  This is the only build that works for newly installed Windows 10 Enterprise with TH2 (1511).

Dropboxer

Re: Experimental Build 3.11.45

Hi Jonathan / Doug,

Thanks for letting us know!  Jonathan, would you be willing to try uninstalling Dropbox and reinstalling 3.10?  I've modified a setting that might help and it would help us isolate the issue if you went through the login flow on 3.10.  (Doug, it looks like you have a larger number of files so I wouldn't recommend downgrading since it will cause a resync).

https://www.dropboxforum.com/hc/en-us/community/posts/204347726-Stable-Build-3-10-11

Thanks!

John

Re: Experimental Build 3.11.45

there is an issue with Bitdefender, Dropboxuninstaller.exe with virus virus zum.androm.1

Level 2

Re: Experimental Build 3.11.45

Greetings - new to the forum, but I'll try to keep the noob questions to a minimum.   I've only used DB in a somewhat peripheral, i.e. not very in-depth, way - basically to just share &| backup a few files among Win & Android devices.  I'm running 3.10.11 on win 8.1.  The reason I'm posting here is that I want to upgrade the win client and I'm not so afraid of test and RC builds really.  I've noticed a separation between 3.10, 3.11 and 3.12 codelines/builds and I'm wondering if there is some reason to avoid moving from say, 3.10 to 3.11 or 3.12.  BUT - I see in this announcement for 3.11.45 that there is an edit/note that says there is a NEWER RC - and it points at the 3.12.2 Release Candidate.  This implies that it might be ok, perhaps recommended, to move toward 3.12.x RC.

I'm very aware of the need to be careful about the word "recommend" and - well - how potentially hostile an invested group of users can become; i.e. I'm a sw dev and worked in bugfix at Sybase for many years fixing and building RCs and one-off's, etc.. - I know how unappreciated the role can seem.  lol..  TLwinking faceR and I apologize.  I'm thinking I should go ahead and give the 3.12 RC a try - but if there are known issues moving from an older, 3.10.x level, naturally I'd want to at least be aware.  Bear in mind that I'm not the one to blame developers for unforeseen complications, esp. in a large installed base, where if it CAN happen, it WILL happen to some sub-group of daring users.  Test builds and RC's are "use at your own peril" imho - if it doesn't say "stable", then I can't have too many expectations - just hopes.  Again, apologies for the novel - I'll make sure it's the only one winking face   doh.  To clarify, I'm just asking if there are any recommendations between using this 3.11.45 build vs the 3.12.2 RC -- or if I should be "concerned" about potential/known incompatibilities across the code-lines.

Stephen F. - aprilia1k