Announcements
Do you have an idea for Dropbox Paper? Share it with us here!

Webhook Returning Empty Response Error

Helpful | Level 6

I have 3 apps that are configured identically. 2 Development and 1 production.

Each has a webhook URL specified. The live production one keeps erroring out with the below error. I can immediately re-enable it. It looks like a connectivity issue, however, I don't experience this error anywhere else. That endpoint terminates at Cloudflare's edge, so there should never be an empty response. Once I re-enable it, it says enabled for a few minutes (but doesn't deliver any messages) and then errors out again.

I temporarily solved this problem by adding the same endpoint twice, one errored out, and one worked successfully. Still no webhook delivery but no errors on the duplicate. Eventually, I removed the first one and its been working since.  Again, while the production app is error out, the dev apps are humming along. They have the same endpoints.

What's also concerning is, I don't get any notification or email when this occurs, it just stops working. Are there no notifications that are sent out when a problem like this occurs?

Actual Error:

"Error: Did not receive a response from the server.

Request:
POST <URL>

Response:
HTTP/1.1 N/A Unknown

Response Body (First 256 bytes):
(No response body)"

2 Replies

Re: Webhook Returning Empty Response Error

Dropboxer

Thanks for the report. If/when a webhook URI is automatically disabled, we do send an email notifying you of that. Please make sure that the email address on the account that owns the app is up to date and can receive email from the official Dropbox email domains.

It sounds like this the webhooks functionality is working for you now, so it may have been a transient network disruption. If you see this again though, please open an API ticket with the relevant app key(s) and webhook URI(s) so we can investigate this specifically. Thanks!

Reply
Loading...
Highlighted

Re: Webhook Returning Empty Response Error

Helpful | Level 6

Hi Greg,

Thanks for the quick response. I did update my email earlier, although it was previously using a google email, and it wasn't coming into spam or trash. That's good to know though, hopefully, I will get an email if it comes up again. I will review what you linked.

On the webhook issue, it was doing this for the last 24 hours. My attempts to fix included removing and re-adding. It only started working when I added it twice, waited 10 minutes, and then removed the errored one. It's very odd. No problems since. That does not fit the profile of a network issue.

Thanks again!

Derek

Reply
Loading...
Developer & API Discussions

Have a question? Our Dropbox Community is here to help you find an answer!
You won’t have to wait too long for a reply, but why not learn more about the Community while you’re here.

Not the right discussion for you? Find out what else our Community has to say about Developer & API Discussions.

Or, search our Help Center for even more.