cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Update: Find information on Dropbox support during COVID-19 here
Close
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Cannot build with the latest Dropbox v2 API 4.2.3 version

Helpful | Level 6

Hello, I am absolutely happy with the new Dropbox v2 API. Amazing work, thank you. I cannot however update from 4.2.0 to 4.2.3 version. It is probably a minor problem with the versioning of your library. When I look at the details I can see Version 0.1.6274.34602 but the following error message mentions missing assembly of version 0.1.6274.34603.

 

Could not load file or assembly 'Dropbox.Api, Version=0.1.6274.34603, Culture=neutral, PublicKeyToken=310f0e82fbb45d01' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

 

Could you please confirm / fix?

 

Best regards

Jan

 

1 Accepted Solution

Accepted Solutions
Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Dropboxer
Dropboxer

Please try the latest release, v4.2.4, and let us know if you're still seeing any issues. Thanks!

View solution in original post

7 Replies 7
Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Dropboxer
Dropboxer
Thanks for the report Jan. It looks like the assembly reference in your project settings is inconsistent with the actual binary. Please try uninstalling and reinstalling the package and let us know if that doesn't help.
Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Helpful | Level 6

Hi Greg,

 

Thank you very much for following up. I tried your tip but it led to the same results. I am afraid the problem really is in your package, not in my solution. Please try to look at this screenshot. I analyzed content of your two packages: 1) of Dropbox.Api.4.2.3 and 2) of Dropbox.Api.4.2.0.

 

In both cases I compared details of Dropbox.Api.dll in these 3 subfolders: net45, portable-net40+sl5+wp80+win8+wpa81, portable-net45+wp80+win8+wpa81+dnxcore50.

 

In the first case the version numbers of all 3 are inconsistant. They vary between  0.1.6274.34602 and  0.1.6274.34603 - as my original post described. In the second case (your older NuGet version) it is absolutely consistant - it is always  0.1.6263.32141.

 

Probably the reason why nobody else (?) haven't discovered that problem is because in my solution Mvvm framework is used and that one probably uses some level of refection under the hood. I can clearly see when the problem happens and I am pretty sure the root cause is the above mentioned inconsistency.

 

Or is such an inconsistancy expected? If yes, why has it been introduced recently?

 

Best regards

Jan

Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Dropboxer
Dropboxer
Thanks for following up with the additional information. We'll look into it.
Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Dropboxer
Dropboxer
We're investigating ways to avoid this in the next release. Please skip this release for now.
Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Helpful | Level 6

Cool. Thank you. Sure, I am skipping this release and will hope the next one will work for my solution.

Best regards, Jan

Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Dropboxer
Dropboxer

Please try the latest release, v4.2.4, and let us know if you're still seeing any issues. Thanks!

View solution in original post

Highlighted

Re: Cannot build with the latest Dropbox v2 API 4.2.3 version

Helpful | Level 6

4.2.4 worked like a charm! Thank you very much

Work Smarter with Dropbox

The way we work is changing. Share and discover new ways to work smarter with Dropbox in our community.

Sound good? Let's get started.
Who's talking

Top contributors to this post

What do Dropbox user levels mean?
Need more support?