cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Update: Find information on Dropbox support during COVID-19 here
Close
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Dropbox_2020.03.04_amd64.deb and Debian Buster

Helpful | Level 6

Yesterday I installed Debian Buster on a netbook that is not powerful enough for Windows 10.

I tried to install Dropbox but I got an error about python3 and python3-gi not meeting the requirements. The picture shows the Dutch message, I don't know what the English version would be like.

2020-03-14-095055_1024x600_scrot.png

The installed python3 is version 3.7.3-1 and python3-gi 3.30.4-1 so I don't get the point.

 

Anybody?

1 Accepted Solution

Accepted Solutions
Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Helpful | Level 6

Hi @Здравко , you were right about the 32bit vs 64bit question: allthough both the boot message and the uname command say "amd64" I have a 32bit Debian. I'v got the CLI dropbox working now.

Thanks for your help.

View solution in original post

10 Replies 10
Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Super Collaborator | Level 20

Hi @Wijnand,

First make sure everything installed is up to date:

sudo apt-get update
sudo apt-get upgade

Now, check what is the actual version of the installed packages and try install using 'dpkg':

dpkg-query -s python3 python3-gi | grep -e "Package: " -e "Version: "
dpkg -i Downloads/dropbox_2020.03.04_amd64.deb

What is the result?

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Helpful | Level 6

Thank you for the advice, but the result is the same:

- versions 3.7.3-1 and 3.30.4-1 for python3 and python3-gi

- problems with the requirements prevent configuration of dropbox:amd64

2020-03-14-144622_1024x600_scrot.png

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Super Collaborator | Level 20

You didn't show other results. Anyway... try following:

apt-get install procps python3-gi python3 libatk1.0-0 libc6 libcairo2 libglib2.0-0 libgtk-3-0 libpango1.0-0 lsb-release gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-pango-1.0 nautilus python3-gpg

Execute entire line at once. Just a check - if some package is missing (not only python related). What is the output?

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Helpful | Level 6

I got:

pi@mini:~ $ sudo apt-get install procps python3-gi python3 libatk1.0-0 libc6 libcairo2 libglib2.0-0 libgtk-3-0 libpango1.0-0 lsb-release gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-pango-1.0 nautilus python3-gpg
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De statusinformatie wordt gelezen... Klaar
libatk1.0-0 is reeds de nieuwste versie (2.30.0-2).
libatk1.0-0 staat ingesteld op handmatig geïnstalleerd.
libcairo2 is reeds de nieuwste versie (1.16.0-4).
libcairo2 staat ingesteld op handmatig geïnstalleerd.
gir1.2-gdkpixbuf-2.0 is reeds de nieuwste versie (2.38.1+dfsg-1).
gir1.2-gdkpixbuf-2.0 staat ingesteld op handmatig geïnstalleerd.
libglib2.0-0 is reeds de nieuwste versie (2.58.3-2+deb10u2).
libglib2.0-0 staat ingesteld op handmatig geïnstalleerd.
libc6 is reeds de nieuwste versie (2.28-10).
gir1.2-glib-2.0 is reeds de nieuwste versie (1.58.3-2).
gir1.2-glib-2.0 staat ingesteld op handmatig geïnstalleerd.
python3-gpg is reeds de nieuwste versie (1.12.0-6).
lsb-release is reeds de nieuwste versie (10.2019051400).
lsb-release staat ingesteld op handmatig geïnstalleerd.
gir1.2-pango-1.0 is reeds de nieuwste versie (1.42.4-7~deb10u1).
gir1.2-pango-1.0 staat ingesteld op handmatig geïnstalleerd.
procps is reeds de nieuwste versie (2:3.3.15-2).
python3-gi is reeds de nieuwste versie (3.30.4-1).
python3 is reeds de nieuwste versie (3.7.3-1).
gir1.2-gtk-3.0 is reeds de nieuwste versie (3.24.5-1+rpt2).
gir1.2-gtk-3.0 staat ingesteld op handmatig geïnstalleerd.
libgtk-3-0 is reeds de nieuwste versie (3.24.5-1+rpt2).
libgtk-3-0 staat ingesteld op handmatig geïnstalleerd.
U kunt 'apt --fix-broken install' uitvoeren om dit op te lossen.
De volgende pakketten hebben niet-voldane vereisten:
dropbox:amd64 : Vereisten: python3-gi:amd64 (>= 3.12) maar het zal niet geïnstalleerd worden
Vereisten: python3:amd64 (>= 3.4.0) maar het zal niet geïnstalleerd worden
Vereisten: libatk1.0-0:amd64 (>= 2.10) maar het zal niet geïnstalleerd worden
Vereisten: libc6:amd64 (>= 2.19) maar het zal niet geïnstalleerd worden
Vereisten: libcairo2:amd64 (>= 1.13) maar het zal niet geïnstalleerd worden
Vereisten: libglib2.0-0:amd64 (>= 2.40) maar het zal niet geïnstalleerd worden
Vereisten: libgtk-3-0:amd64 (>= 3.10. maar het zal niet geïnstalleerd worden
Vereisten: libpango1.0-0:amd64 (>= 1.36.3) maar het zal niet geïnstalleerd worden
Vereisten: gir1.2-gdkpixbuf-2.0:amd64 (>= 2.30.7) maar het zal niet geïnstalleerd worden
Vereisten: gir1.2-glib-2.0:amd64 (>= 1.40.0) maar het zal niet geïnstalleerd worden
Vereisten: gir1.2-gtk-3.0:amd64 (>= 3.10. maar het zal niet geïnstalleerd worden
Vereisten: gir1.2-pango-1.0:amd64 (>= 1.36.3) maar het zal niet geïnstalleerd worden
libpango1.0-0 : Vereisten: libpangox-1.0-0 (>= 0.0.2-2~) maar het zal niet geïnstalleerd worden
nautilus : Vereisten: libnautilus-extension1a (= 3.30.5-2) maar het zal niet geïnstalleerd worden
Vereisten: nautilus-data (= 3.30.5-2) maar het zal niet geïnstalleerd worden
Vereisten: tracker maar het zal niet geïnstalleerd worden
Vereisten: libgexiv2-2 (>= 0.10.0) maar het zal niet geïnstalleerd worden
Vereisten: libgnome-autoar-0-0 (>= 0.2.1) maar het zal niet geïnstalleerd worden
Vereisten: libtracker-sparql-2.0-0 (>= 1.12.0) maar het zal niet geïnstalleerd worden
Aanbevelingen: gnome-sushi maar het zal niet geïnstalleerd worden
E: Er zijn niet-voldane vereisten. U kunt best 'apt --fix-broken install' uitvoeren zonder pakketten op te geven, (of u kunt zelf een oplossing specificeren).

Then I ran "sudo apt purge Dropbox:amd64" to get rid of the bad dpkg install. 

I ran your suggested command line again and then libpangox-1.0-0:i386 and libpango1.0-0:i386 were installed.

 

After that I tried "sudo apt install ./Downloads/*deb" again, with the same error with python3:amd64 and python3-gi:amd64 as a result.

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Super Collaborator | Level 20

Wait for a moment, are you running on 32-bit or 64-bit platform? To be honest, I don't understand fully everything in the common text, but as could be seen, your system install 32-bit version of the packages by default. This is normal for 32-bit Linux install setup. In this context, why you try install 64-bit Dropbox application? Try download and install 32-bit version (as seems your Linux platform).

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Helpful | Level 6

uname -m gives "x86_64"

 

I tried yid your commandline again with ":amd64" padded to all packages, but no difference.

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Super Collaborator | Level 20

Wow... That's strange. Something got wrong with your system setup. From now on, I can only speculate what the reason could be. Try check, one by one, availability for every one of the required packages (which I listed above), using "dpkg-query -s <package name>".  Check for (and install if missing) both 32 and 64 bit package versions. Otherwise you can try install/copy the two important files from the Dropbox package by hand (the nautils plugin and the control script), which would be enough (the desktop file for convenient starting, also). I can't say anything more.

Good luck.

Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Super Collaborator | Level 20

Try following:

sudo apt-get install python3:amd64 python3-gi:amd64
Highlighted

Re: Dropbox_2020.03.04_amd64.deb and Debian Buster

Helpful | Level 6

Already did: no joy...

 

Thanks anyway.

Work Smarter with Dropbox

The way we work is changing. Share and discover new ways to work smarter with Dropbox in our community.

Sound good? Let's get started.
Who's talking

Top contributors to this post

What do Dropbox user levels mean?
Need more support?