cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Want to know all about tools for creatives that work seamlessly with Dropbox, like Adobe? Well, check it out right here!

Dropbox installs & integrations

Connect your tools and content together with help from the Dropbox Community. Join a discussion or post a question of your own to get started.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Latest version of dropbox not compatible

Latest version of dropbox not compatible

Dreemer01
New member | Level 2

Dropbox must have just issued an update as my app is now grey on my macbook air and it says that I need OS 10.10 or higher to use the app. I can't upgrade my OS system because I won't be able to use some of my older programs. Is there a way to go back to an earlier version of dropbox? Any other solutions?

1 Accepted Solution

Accepted Solutions

Re: Latest version of dropbox not compatible

Lusil
Dropboxer
Hi there @Dreemer01
 
The current system requirements to run the desktop app on a Mac device need OS X Yosemite (10.10) up to macOS Mojave (10.14). 
 
If you're not able to update your OS, don’t worry, your files will remain safe in your Dropbox account, and you can access them from another supported device, or through the website if you're using a supported browser.
 
Finally, please note that new version of the desktop app are regularly released with additional features and better performance. For this reason, we don't recommend using previous versions, as the latest version includes the most up-to-date fixes, security updates, and you may encounter installation errors when attempting to revert to a previous version of the app.
 
Let me know if you have any other questions!

Lusil
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, please give it a Like below.
:arrows_counterclockwise: Still stuck? Ask me a question!
:pushpin: Tips & Tricks Find new ways to stay in flow or share your tips on how you work smarter with Dropbox.

View solution in original post

4 Replies 4

Re: Latest version of dropbox not compatible

Lusil
Dropboxer
Hi there @Dreemer01
 
The current system requirements to run the desktop app on a Mac device need OS X Yosemite (10.10) up to macOS Mojave (10.14). 
 
If you're not able to update your OS, don’t worry, your files will remain safe in your Dropbox account, and you can access them from another supported device, or through the website if you're using a supported browser.
 
Finally, please note that new version of the desktop app are regularly released with additional features and better performance. For this reason, we don't recommend using previous versions, as the latest version includes the most up-to-date fixes, security updates, and you may encounter installation errors when attempting to revert to a previous version of the app.
 
Let me know if you have any other questions!

Lusil
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, please give it a Like below.
:arrows_counterclockwise: Still stuck? Ask me a question!
:pushpin: Tips & Tricks Find new ways to stay in flow or share your tips on how you work smarter with Dropbox.

View solution in original post

Re: Latest version of dropbox not compatible

nilo1
New member | Level 2

Update my entire system just to use Dropbox?  Dropbox should instead support earlier systems.  Verges on dishonesty, arrogance for sure.  Try having a product that normal people can use, instead of making everyone arrive at your neverending new standards. Very unhappy with Dropbox.

Re: Latest version of dropbox not compatible

Lusil
Dropboxer
Hi there @nilo1
 
In general, new versions of the desktop app are released with additional features, better performance, and enhanced security. These versions are not always compatible with older OS
 
Nonetheless, I’d be more than happy to pass your comments along to the dev team for future consideration. 
 
Let me know if you have any other questions!

Lusil
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, please give it a Like below.
:arrows_counterclockwise: Still stuck? Ask me a question!
:pushpin: Tips & Tricks Find new ways to stay in flow or share your tips on how you work smarter with Dropbox.

Re: Latest version of dropbox not compatible

JimGrisham
New member | Level 2

See the discussion at the following link, Mac OS 10.9 end of support, for more discussion and possible workarounds if you cannot update past MacOS 10.9 at this time.

https://www.dropboxforum.com/t5/Installation-and-desktop-app/Mac-OS-10-9-end-of-support/td-p/316519

Poll
Do you work or study in the creative industry? If so, which area?
If you use Adobe, don't forget to check out our latest integrations update here.
Who's talking

Top contributors to this post

  • User avatar
    JimGrisham New member | Level 2
  • User avatar
    Lusil Dropboxer
  • User avatar
    nilo1 New member | Level 2
What do Dropbox user levels mean?
Need more support?