cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Update: Find information on Dropbox support during COVID-19 here
Close

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

API Docs out of date ?

Explorer | Level 3

I am trying to quickly implement the v2 API, having discovered by error message that the v1 servers no longer run.

 

The documents I see refer to DBClientManager instead of DropBoxClientManager and the setResponse examples etc are not working.

 

Is this doc out of date? Is there a more up to date doc somewhere?

 

I am having a bit of a rough Canadian thankgivver here.

 

 

1 Accepted Solution

Accepted Solutions
Highlighted

Re: API Docs out of date ?

Dropboxer
Dropboxer

The latest version of the SDK is v3.3.3. If you're using 1.1.1, you will see the discrepancies with the current documentation you mentioned. We recommend updating to the latest version. For Cocoapods, you'lld need to run `pod update`. If your Podfile is set to require 1.1.1 (or some other version) specifically, remove the version number first (so that it looks like the sample) before the `pod update`.

View solution in original post

4 Replies 4
Highlighted

Re: API Docs out of date ?

Dropboxer
Dropboxer

@mrschulz I'm sorry to hear this caught you unaware. We notified developers by email, but it sounds like those emails unfortunately did not make it to you. If you need more time to migrate your app to API v2, we can offer an extension for access to API v1. To request that, please open an API ticket with the relevant app key(s).

 

Anyway, it sounds like you're referring to the official Objective-C SDK for Dropbox API v2. That documentation is up to date. What version of the SDK do you have installed? The latest version is 3.3.3. It sounds like you may be using an older version of the SDK itself. There were some renamed classes at one point.

Highlighted

Re: API Docs out of date ?

Explorer | Level 3

Hi Greg

 

  Which version of the API is the newest? I am using the Cocoapod.

 

  In the docs, DBClientsManager is referenced, while I am using DropboxClientsManager in the code.

 

  Furthermore, thinks like the setResponse are not there - instead I have to use 'response'

 

  The Podfile I am using is 1.1.1 

 

   For this pod, the example code does not compile. 

 

    I am going to open up this ticket you suggested so I can stop panicking, my customers are locked out and I am like a day of dev time plus Store cycle away from fixing this.

 

 

Highlighted

Re: API Docs out of date ?

Dropboxer
Dropboxer

The latest version of the SDK is v3.3.3. If you're using 1.1.1, you will see the discrepancies with the current documentation you mentioned. We recommend updating to the latest version. For Cocoapods, you'lld need to run `pod update`. If your Podfile is set to require 1.1.1 (or some other version) specifically, remove the version number first (so that it looks like the sample) before the `pod update`.

View solution in original post

Highlighted

Re: API Docs out of date ?

Explorer | Level 3

pod update was the key there. Derp.

 

Thanks for the quick response on my other ticket; I have v1 access for a few months now, but having the right pod will let me finish this quickly too.

 

Great response time, thanks a bunch, wish I reached out sooner.

 

Polls
Do you know how to organize your files and folders?
We have created a guide on folder best practice, so you can get organized now check it out here.

Work Smarter with Dropbox

The way we work is changing. Share and discover new ways to work smarter with Dropbox in our community.

Sound good? Let's get started.
Who's talking

Top contributors to this post

What do Dropbox user levels mean?
Need more support?