Showing results for 
Show  only  | Search instead for 
Did you mean: 
Organizing your research is important to easily review and share it. Learn how Kim uses Dropbox to gather and organize her research right here.

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't build for iOS Simulator when SDK installed with Carthage

Re: Can't build for iOS Simulator - **SOLVED**

Robert S.138
Helpful | Level 7



The main problem was that the Intel 64-bit architecture was not recognized by XCODE as on of the build architectures. That in turn was caused by the update to XCODE 12.  Even though the architectures were properly indicated as $(ARCHS_STANDARD) in both the project and the target build settings, they were being overriden by a setting in the USER-DEFINED section of the build settings that XCODE transferred there for some reason.  The setting in USER-DEFINED was


VALID_ARCHS     armv7  arm64


The solution was to click on this setting and hit DELETE so it totally vanishes.  Then the main project build settings that include all standard architectures can be effective.  It was odd that this error led to the error "ObjectiveDropboxOfficial/ObjectiveDropboxOfficial.h" not found.  But perhaps it had to do with CocoaPods making a copy of the header files for each architecture, because this error did not happen when building for a real device.  Anyway, it is solved.


Oh, I gave up on Carthage and returned to my original Cocoapods setup.  Also I updated Cocoapods to the latest, version 1.10.0 with


  sudo gem install cocoapods


Also I updated the ObjectiveDropboxOfficial project to ver 5.0.3  with:


   pod update

   pod deintegrate

   pod install


(I don't know if the last two commands were necessary.)


Updating to Dropbox API version 5.0.3 and XCODE 12 only required two small accomodations in my source code.  One was that the type of the first parameter in the response block for the function createFolderV2 had to be changed from DBFILESFolderMetadata to DBFILESCreateFolderResult.  The other change was that [DBClientsManager handleRedirectURL] now uses a completion block instead of returning the DBOAuthResult directly.


Anyway, I am back to using Cocoapods and everything is working as it should.


Who's talking

Top contributors to this post

  • User avatar
    Robert S.138 Helpful | Level 7
  • User avatar
    Greg-DB Dropboxer
What do Dropbox user levels mean?
Need more support?