cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Not happy with your Spotify Wrapped? Check out how Kevin on the Dropbox team used Paper to make sure he keeps discovering new music over here.

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1
Ask
2
Comments

Cocopods API v2 installation "Unable to find a specification for `ObjectiveDropboxOfficial`"

Cocopods API v2 installation "Unable to find a specification for `ObjectiveDropboxOfficial`"

smithmsdb
Explorer | Level 3

Hello,

I am attempting to install API v2 into a sample Mac OS project using cocoa pods and get "Unable to find a specification for `ObjectiveDropboxOfficial`". I don't have a lot of experience using dependency managers.

 

What am I doing wrong? Please see output below.

 

Podfile content:
-----------------------------------------------------------------------------------------------

# Uncomment this line to define a global platform for your project
# platform :ios, '9.0'
target 'DBMacApp' do
# Uncomment this line if you're using Swift or would like to use dynamic frameworks
# use_frameworks!
# Pods for DBMacApp
pod 'ObjectiveDropboxOfficial'
end

 

pod install output:
-----------------------------------------------------------------------------------------------

mark-smiths-imac:DBMacApp smithms$ pod install --verbose
Preparing
Analyzing dependencies
Inspecting targets to integrate
Using `ARCHS` setting to build architectures of target `Pods-DBMacApp`: (``)
Resolving dependencies of `Podfile`
[!] Unable to find a specification for `ObjectiveDropboxOfficial`
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/resolver.rb:442:in `handle_resolver_error'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/resolver.rb:65:in `rescue in resolve'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/resolver.rb:57:in `resolve'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer/analyzer.rb:563:in `block in resolve_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/user_interface.rb:63:in `section'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer/analyzer.rb:561:in `resolve_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer/analyzer.rb:76:in `analyze'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer.rb:227:in `analyze'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer.rb:151:in `block in resolve_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/user_interface.rb:63:in `section'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer.rb:150:in `resolve_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/installer.rb:114:in `install!'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/command/install.rb:37:in `run'
/Library/Ruby/Gems/2.0.0/gems/claide-1.0.0/lib/claide/command.rb:334:in `run'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/command.rb:50:in `run'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/bin/pod:55:in `<top (required)>'
/usr/local/bin/pod:23:in `load'
/usr/local/bin/pod:23:in `<main>'
mark-smiths-imac:DBMacApp smithms$ 

 

1 Accepted Solution

Accepted Solutions

Re: Cocopods API v2 installation "Unable to find a specification for `ObjectiveDropboxOfficial`

Greg-DB
Dropboxer

That is the right pod name, but have you run `pod setup` yet? Try that if you haven't. If you have, try `pod repo update`.

View solution in original post

2 Replies 2

Re: Cocopods API v2 installation "Unable to find a specification for `ObjectiveDropboxOfficial`

Greg-DB
Dropboxer

That is the right pod name, but have you run `pod setup` yet? Try that if you haven't. If you have, try `pod repo update`.

Re: Cocopods API v2 installation "Unable to find a specification for `ObjectiveDropboxOfficial`

smithmsdb
Explorer | Level 3

Yes, after some additional research, I found the suggestion to run ‘pod repo update’.
I then ran ‘pod install’ again and it seemed to work fine.

Thanks so much for your quick response.

Who's talking

Top contributors to this post

  • User avatar
    smithmsdb Explorer | Level 3
  • User avatar
    Greg-DB Dropboxer
What do Dropbox user levels mean?
Need more support?