cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Back again with another edition of 'How we use Dropbox', so find out how Emma uses to-do lists to get it all done here!

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Official Ruby Gem outdated

Official Ruby Gem outdated

philister
Explorer | Level 4

Hi,

 

using the official Ruby Gem, maintained by dropbx inc (https://rubygems.org/gems/dropbox-sdk). I is now oudated(?) It fails in parts with "v1 retired"

Our users are using it daily and I believed the official gem would be compatible to v2.

 

What to do?

 

Thanks and regards, Phil

2 Replies 2

Re: Official Ruby Gem outdated

Greg-DB
Dropboxer

@philister The Ruby Core SDK (source) does use API v1, so further API calls made with it will fail. Unfortunately we don't have plans for an official Ruby SDK for Dropbox API v2. I'm sending this along as a feature request for one though.

Instead, you can use the HTTPS endpoints themselves or a third party library.

 

If you need more time to migrate your app to API v2, we can offer an extension for access to API v1. To request that, please open an API ticket with the relevant app key(s).

Re: Official Ruby Gem outdated

philister
Explorer | Level 4

Thanks for your support and quick response, Greg!

 

Nevertheless it is a kind of no go to drop a working API and, worse, don't support the new API by maintaining official(!), non-community libraries. 

 

Regards, Phil

Who's talking

Top contributors to this post

  • User avatar
    philister Explorer | Level 4
  • User avatar
    Greg-DB Dropboxer
What do Dropbox user levels mean?
Need more support?