cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Back again with another edition of 'How we use Dropbox', so find out how Emma uses to-do lists to get it all done here!

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SwiftyDropbox and IPV6 compatibility

SwiftyDropbox and IPV6 compatibility

Joe Z.1
Explorer | Level 3

Team - I have an app using SwiftyDropbox rejected from App Store due to IPV6 incompatibility. Do you know if this may result from SwiftyDropbox? In other words, is SwiftyDropbox IPV6 compatible in general? This was with the iOS 9 / Xcode 7 Version. I am now using Swift 3 and have updated to your latest libraries using 'pod update', so I will give it another try in the next days.

Thanks .. Joe

2 Replies 2

Re: SwiftyDropbox and IPV6 compatibility

Stephen C.14
Dropboxer

@Joe Z.: Thanks for reaching out. Given that the SDK defers most of its network functionality to Alamofire, I'm pretty confident that updating to the latest version of SwiftyDropbox (and by extension, Alamofire), should resolve any IPv6 compatibility issues, if they were in fact due to the SDK.

Let us know if you run into the same issue when submitting your app with the latest version of SwiftyDropbox.

Re: SwiftyDropbox and IPV6 compatibility

Joe Z.1
Explorer | Level 3

@Stephen: thank you for your comment. I have now successfully deployed my app to the app store, using the latest version of SwiftyDropbox.

Who's talking

Top contributors to this post

  • User avatar
    Joe Z.1 Explorer | Level 3
  • User avatar
    Stephen C.14 Dropboxer
What do Dropbox user levels mean?
Need more support?