Showing results for 
Show  only  | Search instead for 
Did you mean: 
Are you interested in hearing how one of our Community members uses Dropbox for sailing trips? Read all about it here.

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re: /oauth2/authorize never ends - Windows, VS2019, native C++, desktop app, CEF

/oauth2/authorize never ends - Windows, VS2019, native C++, desktop app, CEF

Explorer | Level 3

As a software developer company, we would like to give Dropbox feature to our native C++ MFC desktop app. 
As we can't use the IE browser anymore, we have to look for another browser solution.

We tried to use CEF, and we could succesfully integrate it into our app.

Because the CEF needs so many exe instances and our desktop exe can't handle this behaviour, we use a small proxy exe to work with CEF.
We implemented the "code flow" authorization.
We use this kind of url:<our_client_id>&force_reauthentication=false&loca...

Of course, "our_client_id", "our_redirect_uri" and "our_state" has valid values.

Unfortunatelly this authentication worklow sometimes works, but simetimes doesn't. 

When not then the tipical problem is: when the small proxy exe shows the Dropbox's login screen, and we enter a valid email and password pair, and then try to sing-in, the cursor became "busy", and will never ends, so the browser won't ever redirected to the given url. 

The interesting is that there are machines where this workflows works very well, but there are other machines where is doesn't.

"Doesn't work": I mean that the busy cursor remains active, and we never get redirected to the given redirect_uri (neither anywhere else).

Machines means: Win10x32, Win10x64.

Our small proxy exe is based on the CEF's cefsimple app, but we added some extra codes because we need to communicate backwards our desktop exe.
We tried the original "cefsimple" app also, and we experienced that it also can't redirect.

Then we tested with the Microsoft's Edge on the very same machine, so the Edge also suffer from this "endless process" problem.

The Edge version is: "88.0.705.50 (Official build)(64-bit)" - actually the most up-to-date version.

Is it possible that this is bug in the Dropbox?

2 Replies 2

Dropbox Staff

By "CEF", I believe you're referring to Chromium Embedded Framework. Please note that this is not officially supported for processing the Dropbox app authorization flow, which should only be processed in the user's system browser.


It sounds like you also saw this issue in Edge itself though, which is supported. I just tried the /oauth2/authorize URL you shared, plugging in a valid client ID, redirect URI, and state value, and it worked in that same version of Edge for me though. 


If you're still seeing this issue in Edge, we'll be happy to look into it, but we'll need a way to reproduce the issue. Can you share the steps and a full URL where we can reproduce it? Feel free to open an API ticket if you'd prefer to share privately. Thanks!

Explorer | Level 3

Hi Greg,

Thanks for the answer, I opened an API ticket with the very same title on it, the discussion continues there.

Thanks again!

- Gyorgy

Need more support?