cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Back again with another edition of 'How we use Dropbox', so find out how Emma uses to-do lists to get it all done here!

Dropbox API Support & Feedback

Find help with the Dropbox API from other developers.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't install: 192.168.1.18 port 22: Broken pipe

Can't install: 192.168.1.18 port 22: Broken pipe

simon_schva
Helpful | Level 6

Hi, when trying to install the API the process starts OK but ends with 192.168.1.18 port 22: Broken pipe and the API is not installed. I would appreciate any hint on how to fix it. Many thanks in advance

 

Complete trace below

 

 

root@Yun3:~# pip install --target /mnt/sda1/python-packages dropbox
Collecting dropbox
/usr/lib/python2.7/site-packages/pip-9.0.1-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/usr/lib/python2.7/site-packages/pip-9.0.1-py2.7.egg/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Downloading dropbox-8.0.0-py2-none-any.whl (392kB)
    100% |################################| 399kB 7.2kB/s 
Collecting six>=1.3.0 (from dropbox)
  Downloading six-1.10.0-py2.py3-none-any.whl
Collecting requests!=2.16.0,!=2.16.1,!=2.6.1,>=2.5.1 (from dropbox)
  Downloading requests-2.18.3-py2.py3-none-any.whl (88kB)
    100% |################################| 92kB 30kB/s 
Collecting urllib3 (from dropbox)
  Downloading urllib3-1.22-py2.py3-none-any.whl (132kB)
    100% |################################| 133kB 23kB/s 
Collecting idna<2.6,>=2.5 (from requests!=2.16.0,!=2.16.1,!=2.6.1,>=2.5.1->dropbox)
  Downloading idna-2.5-py2.py3-none-any.whl (55kB)
    100% |################################| 61kB 68kB/s 
Collecting certifi>=2017.4.17 (from requests!=2.16.0,!=2.16.1,!=2.6.1,>=2.5.1->dropbox)
  Downloading certifi-2017.7.27.1-py2.py3-none-any.whl (349kB)
    100% |################################| 358kB 7.1kB/s 
Collecting chardet<3.1.0,>=3.0.2 (from requests!=2.16.0,!=2.16.1,!=2.6.1,>=2.5.1->dropbox)
  Downloading chardet-3.0.4-py2.py3-none-any.whl (133kB)
    100% |################################| 143kB 12kB/s 
Installing collected packages: six, idna, certifi, urllib3, chardet, requests, dropbox
packet_write_wait: Connection to 192.168.1.18 port 22: Broken pipe

 

2 Accepted Solutions

Accepted Solutions

Re: Can't install: 192.168.1.18 port 22: Broken pipe

Greg-DB
Dropboxer

@simon_schva This error is occurring with pip itself, and not the Dropbox library, so I'm afraid we can't offer help for this in particular. (It looks like it may be failing when trying to SSH to an address on your local network.) 

View solution in original post

Re: Can't install: 192.168.1.18 port 22: Broken pipe

simon_schva
Helpful | Level 6

Thanks Greg. I was installing on an Arduino Yun with a Wifi connection. When using a cable connection the Broken pipe message goes away.

View solution in original post

2 Replies 2

Re: Can't install: 192.168.1.18 port 22: Broken pipe

Greg-DB
Dropboxer

@simon_schva This error is occurring with pip itself, and not the Dropbox library, so I'm afraid we can't offer help for this in particular. (It looks like it may be failing when trying to SSH to an address on your local network.) 

View solution in original post

Re: Can't install: 192.168.1.18 port 22: Broken pipe

simon_schva
Helpful | Level 6

Thanks Greg. I was installing on an Arduino Yun with a Wifi connection. When using a cable connection the Broken pipe message goes away.

View solution in original post

Poll
We love to learn from the educators who use Dropbox. Whether you teach kids, teens, adults or a combination of all three, we want to know what apps and integrations you use with Dropbox to help with teaching. Which of the ones below is your favorite, or most used tool?
Who's talking

Top contributors to this post

  • User avatar
    simon_schva Helpful | Level 6
  • User avatar
    Greg-DB Dropboxer
What do Dropbox user levels mean?
Need more support?