cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Share your feedback on the Document Scanning Experience in the Dropbox App right here.

Apps and Installations

Have a question about a Dropbox app or installation? Reach out to the Dropbox Community and get solutions, help, and advice from members.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The installation of dropboxd can't be completed on my linux box

The installation of dropboxd can't be completed on my linux box

Takeshi1
Explorer | Level 3

Hi.

I'm trying to install dropbox on my linux box, which is runnnign Debian 9 (stretch).

1. Download of dropbox
$ cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -


2. Installation (tsuyama means my account)
~/.dropbox-dist/dropboxd

dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-dpL0Tx
dropbox: initializing
dropbox: initializing python 3.5.4
dropbox: setting program path '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/dropbox'
dropbox: setting home path '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93'
dropbox: setting python path '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93:/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/python-packages-35.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/cryptography.hazmat.bindings._constant_time.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/cryptography.hazmat.bindings._openssl.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/cryptography.hazmat.bindings._padding.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/psutil._psutil_linux.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/psutil._psutil_posix.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/linuxffi.pthread._linuxffi_pthread.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/cpuid.compiled._cpuid.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/linuxffi.fcntl._linuxffi_fcntl.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/linuxffi.sys.compiled._linuxffi_sys.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/linuxffi.resolv.compiled._linuxffi_resolv.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/tornado.speedups.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/linuxffi.gnu.compiled._linuxffi_gnu.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/posixffi.libc._posixffi_libc.cpython-35m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/librsyncffi.compiled._librsyncffi.cpython-35m-x86_64-linux-gnu.so'
 Dropbox ...
https://www.dropbox.com/cli_link_nonce?nonce=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx


3. I open the above URL, and I login successfully with my Dropbox account.

4. But, the below message is shown, and the installation seems to be freezed.
dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/PyQt5.QtCore.cpython-35m-x86_64-linux-gnu.so'

My question is how to fix this problem. Any idea?

13 Replies 13

Walter
Dropbox Staff

Hey there @Takeshi1 - sorry to hear about this. 

Can you first ensure you're meeting all of our minimum requirements as per this page: https://www.dropbox.com/help/desktop-web/system-requirements ?

Also, would you mind sending a screenshot of the error too?

Let me know what you find and we'll take it from there. 


Walter
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, give it a Like below to let us know.
:arrows_counterclockwise: Need help with something else? Ask me a question!
:pushpin: Find Tips & Tricks Discover more ways to use Dropbox here!
:arrows_counterclockwise: Interested in Community Groups? Click here to join

Takeshi1
Explorer | Level 3

Hi.

Thank you for your reply.

I'm trying to install Dropbox as a headless. So, the requirements of the headless linux server is Glibc 2.19 or above.

The version of Glibc on Debian stretch is 2.24. I think the requirements has been met.

The last message is as below (see screenshot). The installation is freezed after the message.

dropbox: load fq extension '/home/tsuyama/.dropbox-dist/dropbox-lnx.x86_64-59.4.93/PyQt5.QtCore.cpython-35m-x86_64-linux-gnu.so'

dropbox.png

Walter
Dropbox Staff

Sorry to hear about this @Takeshi1.

At this point, since Debian is not officially supported, I would suggest that you tried an advanced re-install as outlined in this Help Center article and if the issue persists you can also log a ticket with our team providing as much information as possible in regards to your installation issue in the hopes there's something further to be done.

Either way, keep me posted on your findings 


Walter
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, give it a Like below to let us know.
:arrows_counterclockwise: Need help with something else? Ask me a question!
:pushpin: Find Tips & Tricks Discover more ways to use Dropbox here!
:arrows_counterclockwise: Interested in Community Groups? Click here to join

Takeshi1
Explorer | Level 3

Hi Walter. Thank you for your reply.

I reinstalled Dropbox based on your suggestion. But the result is the same as before.

So, I logged a ticket about this problem.

I'm happy to post my findings.


Take care.

Walter
Dropbox Staff

Thanks for your swift and kind response @Takeshi1!

I have found your ticket on our system and replied to you there. Take a look at your email's inbox for my message so we can work on this together :nerd:

Thank you for your patience and cooperation so far.

Cheers

 


Walter
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, give it a Like below to let us know.
:arrows_counterclockwise: Need help with something else? Ask me a question!
:pushpin: Find Tips & Tricks Discover more ways to use Dropbox here!
:arrows_counterclockwise: Interested in Community Groups? Click here to join

rkeire
New member | Level 2

Hi, if you are using GNOME or MATE you can install dropbox packet from the packet manager, Debian already includes a dropbox client. Not sure about KDE though.

damiansz
New member | Level 2

Hey, it's not a solution to take a look into an email's inbox. I have the same issue. Please post here the soluttion!

Walter
Dropbox Staff

Hi @damiansz; thanks for joining our discussion here and sorry to hear you're having issues with installing our desktop app on your Linux machine.

 

May I ask for some additional information like the exact OS and build you're using?

 

If you're getting a specific error, please send me a screenshot  so I can have a look!


Walter
Community Moderator @ Dropbox
dropbox.com/support


Heart Did this post help you? If so, give it a Like below to let us know.
:arrows_counterclockwise: Need help with something else? Ask me a question!
:pushpin: Find Tips & Tricks Discover more ways to use Dropbox here!
:arrows_counterclockwise: Interested in Community Groups? Click here to join

edwardc
Explorer | Level 3

I've essentially the same problem on both Ubuntu 20.04 (Mate) and Mint 20 (Mate), using Dropbox's instruction to download and install:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

~/.dropbox-dist/dropboxd

 

It hangs at:

dropbox: load fq extension '/home/userid/.dropbox-dist/dropbox-lnx.x86_64-100.4.409/PyQt5.QtDBus.cpython-37m-x86_64-linux-gnu.so'

 

FYI, I am attempting to connect to an existing Dropbox account.

Need more support?
Who's talking

Top contributors to this post

  • User avatar
    Walter Dropbox Staff
  • User avatar
    edwardc Explorer | Level 3
What do Dropbox user levels mean?